Problema ao rodar o npm install em ubuntu no Window... | Fórum | School of Net

Deseja poder participar de nosso fórum e tirar todas as suas dúvidas?
Clique aqui e assine nosso plano de acesso ilimitado. Saiba mais.

por Danilo Marcus

1 mês atrás Danilo Marcus

Problema ao rodar o npm install em ubuntu no Windows com WSL2

Olá estou com o seguinte erro abaixo: ``` + npm install npm WARN deprecated [email protected]: This SVGO version is no longer supported. Upgrade to v2.x.x. npm WARN deprecated [email protected]: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility npm WARN deprecated [email protected]: Use your platform's native performance.now() and performance.timeOrigin. [email protected] /var/jenkins_home/workspace/tibranch-pipeline-project_master +-- UNMET PEER DEPENDENCY @testing-library/[email protected]>=7.21.4 +-- @testing-library/[email protected] | `-- @babel/[email protected] | `-- [email protected] +-- [email protected] extraneous +-- [email protected] extraneous +-- [email protected] extraneous +-- [email protected] | `-- [email protected] | `-- [email protected] +-- [email protected] | `-- [email protected] `-- [email protected] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]^2.3.2 (node_modules/react-scripts/node_modules/fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]^2.3.2 (node_modules/jest-haste-map/node_modules/fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]~2.3.2 (node_modules/chokidar/node_modules/fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]~2.3.2 (node_modules/rollup/node_modules/fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) npm WARN [email protected] requires a peer of [email protected]^3.2.1 || ^4 but none was installed. npm WARN [email protected] requires a peer of [email protected]^8.0.1 || ^9.0.0 || ^10.0.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]^8.0.1 || ^9.0.0 || ^10.0.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]^4.0.1 but none was installed. npm WARN [email protected] requires a peer of [email protected]^5.0.2 but none was installed. npm WARN [email protected] requires a peer of [email protected]>= 3.1.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]^4.0.0 || ^5.0.0 || ^6.0.0 || ^7.0.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]^1.3.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]* but none was installed. npm WARN [email protected] requires a peer of [email protected] but none was installed. npm WARN [email protected] requires a peer of [email protected] but none was installed. npm WARN @pmmmwh/[email protected] requires a peer of @types/[email protected] || 5.x but none was installed. npm WARN @pmmmwh/[email protected] requires a peer of [email protected]^1.4.0 but none was installed. npm WARN @pmmmwh/[email protected] requires a peer of [email protected] but none was installed. npm WARN @pmmmwh/[email protected] requires a peer of [email protected] || 1.x but none was installed. npm WARN [email protected] requires a peer of [email protected]^8.0.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none was installed. npm WARN @jest/[email protected] requires a peer of [email protected]^8.0.1 || ^9.0.0 || ^10.0.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]>=9.0.0 but none was installed. npm WARN @jest/[email protected] requires a peer of [email protected]^8.0.1 || ^9.0.0 || ^10.0.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]^2.5.0 but none was installed. npm WARN [email protected] requires a peer of [email protected]^4.0.1 but none was installed. npm WARN [email protected] requires a peer of [email protected]^5.0.2 but none was installed. npm WARN [email protected] requires a peer of [email protected]>= 2.7 but none was installed. npm WARN [email protected] requires a peer of [email protected]* but none was installed. npm WARN [email protected] requires a peer of [email protected]>=9.0.0 but none was installed. npm WARN @apideck/[email protected] requires a peer of [email protected]>=8 but none was installed. npm ERR! Linux 5.10.16.3-microsoft-standard-WSL2 npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" npm ERR! node v6.17.1 npm ERR! npm v3.10.10 npm ERR! path /var/jenkins_home/workspace/tibranch-pipeline-project_master/node_modules/.staging/@types/eslint-scope-82d2c490/package.json npm ERR! code ENOTDIR npm ERR! errno -20 npm ERR! syscall open npm ERR! ENOTDIR: not a directory, open '/var/jenkins_home/workspace/tibranch-pipeline-project_master/node_modules/.staging/@types/eslint-scope-82d2c490/package.json' npm ERR! npm ERR! If you need help, you may report this error at: npm ERR! <https://github.com/npm/npm/issues> npm ERR! Please include the following file with any support request: npm ERR! /var/jenkins_home/workspace/tibranch-pipeline-project_master/npm-debug.log ``` Rodei os seguintes comandos: _____________________________________________________ docker run --name jenkins-docker --rm --detach \ --privileged --network jenkins --network-alias docker \ --env DOCKER_TLS_CERTDIR=/certs \ --volume jenkins-docker-certs:/certs/client \ --volume jenkins-data:/var/jenkins_home \ --publish 2376:2376 \ docker:dind --storage-driver overlay2 _____________________________________________________ docker run --name jenkins-blueocean --restart=on-failure --detach \ --network jenkins --env DOCKER_HOST=tcp://docker:2376 \ --env DOCKER_CERT_PATH=/certs/client --env DOCKER_TLS_VERIFY=1 \ --publish 8080:8080 --publish 50000:50000 \ --volume jenkins-data:/var/jenkins_home \ --volume jenkins-docker-certs:/certs/client:ro \ myjenkins-blueocean:2.361.2-1 ____________________________________________________ meu pipeline: pipeline { agent { docker { image 'node:6-alpine' args '-p 3000:3000' } } environment { CI = 'true' } stages { stage('Build') { steps { sh 'npm install' } } } }

2 Respostas